Monday, April 20, 2015

On Updates & blank textures

OSgrid's newspage has busy times lately. It has more posts than the whole of last 2 years in 1 month. Fist off, a new ini file was added (this moves the OSSL part from the opensim.ini to the config-include folder if I understood correctly). Handy for when you want to run NPC's or one of the awesome Danceballs / other scripted NPC products produced by Aine.

Also there was a pretty serious bork in the asset server. Apparently it has not been writing it's assets to database in the past 3 weeks or so. Caching prevented this issue from being spotted earlier, and the bottom line is, that all the stuff made / uploaded / textured in the last couple of weeks, is now either gone missing or blank. The bug was found on the 16th of April, when emergency patching shutdown the grids login for some hours. The bug has been fixed, but if you clear cache, stuff might look a bit different than when you put it there. Details are in the News page, fist link in this article.

Luckily, its just prims & pixels, and unless you have been creating a world from scratch in the past weeks, it likely boils down to applying a filter (on days) in inventory, delete the blank stuff, and empty trash on website. Smart thing to do afterwards is make sure you grab a IAR copy of your inventory, so you can sleep relaxed knowing all your precious prims are backed up. (If you live in a testgrid, this is a smart idea anyways). If you have been creating new prims on your regions, and need to clean up; you can find all available asset commands on this page.

A new release was issued after the outage, but according to twitter this one is bugged. So do not install this, be patient, and wait until the next release is issued. ( It's there now, you can grab it at the OSG downloadpage )
Did someone already explain you that making your own regular backups makes you a more balanced person ?
Post a Comment